A bunch of cool things

So far, this weekend has been a great one. Met a bunch of old pals again, fixed some long-due problems and even got something productive out of it!

The first cool thing is that Plasma does work correctly now. Yes, this means that this strange behaviour is history and I’m able to freely move plasmoids around the place. Problem was, as usual, not the main program itself but one of the underlying libs: In this case a fresh Qt checkout from KDE’s trunk solved the problem nicely. Yes, it really was that simple. Maybe this will be of help, as nobody on the official support channel really had an answer for that πŸ™‚ .

In order to allow me a quick and dirty playground like that computing power is necessary. Compiling large projects like Qt takes a lot of time it becomes clear that reduction of this compilation time is advised. About a year ago I blogged about Icecream, a nice way of clustering compilation tasks around your network. By the time you read this all of my machines (except for one pesky bugger) are running Linux exclusively so getting a small cluster of dualcore processing power together wasn’t hard, it also allowed me to trash one system and set it up with Debian again, now it’s usable after whooping 10 seconds. Beat that, suckers!

I said to myself “Tsukasa, if you’re already using bleeding edge software like KDE 4.1, Wine and Mplayer then you should use the latest and greatest Mono + toolchain as well”. So I went on compiling Mono and Monodevelop straight from svn. Monodevelop did refuse to start though and presented me with the following error message:

Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object
at MonoDevelop.Core.Runtime.Initialize (Boolean updateAddinRegistry) [0x00000]
at MonoDevelop.Startup.SharpDevelopMain.Main (System.String[] args) [0x00000]

Looking this up on the net didn’t bring any good results, trying to fiddle around with mdtool? No cigar, same message. So, what’s the fix? Simply delete your ~/.config/Monodevelop directory so the Add-In registry has to be rebuilt. Yes, it’s those darn buggers that make everything bad and boo. Now it’s up and running and I’m eagerly trying to build Qyoto now πŸ™‚ .

About Tsukasa

The fool's herald.
This entry was posted in Blog. Bookmark the permalink.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.